Angular 9 报 Invalid package name “__ngcc_entry_points__.json”

最近在某个项目从 Angular 8 升级的时候,允许 npm install 的时候遇到如下报错:

 
npm ERR! code EINVALIDPACKAGENAME
npm ERR! Invalid package name "__ngcc_entry_points__.json": name cannot start with an underscore

网上搜索到的方法主要是讲通过如下操作解决:

rm -rf node_modules
npm install

估计有的人行,但我这里仍然报错。实际上还应该删除 package-lock.json 文件才行。

rm -f package-lock.json

我主要是各种包的版本升级折腾遇到的,估计也是小概率吧。

作者: Ben

IT、电商、零售、医药行业混迹多年的理想主义者。

《Angular 9 报 Invalid package name “__ngcc_entry_points__.json”》有一个想法

评论已关闭。